iThemes Security Pro 5.3.0

iThemes Security Pro was updated to version 5.3.0, from version 5.2.2. Changelog:

  • New Feature: Integration with Have I Been Pwned to prevent users from using passwords found in data breaches.
  • Enhancement: Introduce Password Requirements module for managing and enforcing password requirements.
  • Enhancement: Continually evaluate password strength for users instead of only during registration.
  • Enhancement: Add basic admin debug page to help diagnosing and resolving issues. Particularly with the events.
  • Bug Fix: Password strength would not be evaluated if password was set using custom PHP or CLI commands.
  • Bug Fix: Only hide “Acknowledge Weak Password” checkbox if the user was not allowed to use a weak password.
  • Bug Fix: Ensure Grade Report instructions in the Security Digest is accurate when the Grade score is capped.